Issues with Mollie PSP payments

Incident Report for Ticketmatic

Resolved

Mollie reports the incident as resolved
Posted Oct 28, 2019 - 14:48 CET

Identified

PSP Mollie currently has problems on its platform that causes problems with processing payments. More info and status updates on their status page: https://status.mollie.com/
Posted Oct 28, 2019 - 14:29 CET