Database maintenance
Incident Report for Ticketmatic
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 09, 2018 - 01:56 CET
Identified
We are performing scheduled database maintenance that may cause downtime.
Posted almost 2 years ago. Jan 09, 2018 - 00:57 CET